EAGLE Central Forums
Where the EAGLE community meets. Sponsored by Stratford Digital.

Home » CadSoft Support Forums » eagle.support.eng » tcream layer areas missing
tcream layer areas missing [message #170825] Fri, 23 June 2017 14:20 Go to next message
chris swinson
Messages: 4
Registered: October 2016
Junior Member
I am using Eagle 6.4, and when I export gerber files, it all works as expected, only tcream areas which are not part of actual parts are missing from the gerber export ?

Take for example, if I placed a single SMD capacitor, I would get the 2 pads on the tcream layer, and they would export to gerber as expected. Though if I (for example) added a longer tcream rectangle to the part, then the longer parts would not export.

I know that if I go through all the parts and manually edit the tcream for each part, it would work, but this would take a huge amount of time.  I would have thought eagle would export tcream areas which were manually drawn just like it does on top and bottom layers for example, but it seems not :-(

--
To view any images and attachments in this post, visit:
https://www.element14.com/community/message/224694
Re: tcream layer areas missing [message #170826 is a reply to message #170825] Fri, 23 June 2017 14:47 Go to previous messageGo to next message
Jason Judson
Messages: 4
Registered: June 2017
Junior Member
I have had issues getting them to export if I don't save the board before I export. Also make sure they are on the tcream layer and that your cam processor has a tab that processes just that layer. Hope this helps.

--
To view any images and attachments in this post, visit:
https://www.element14.com/community/message/224696
Re: tcream layer areas missing [message #170827 is a reply to message #170826] Fri, 23 June 2017 15:10 Go to previous messageGo to next message
chris swinson
Messages: 4
Registered: October 2016
Junior Member
Thanks for your thought. The PCB is saved.  If I turn off the tcream layer, then the the whole layer vanishes as expected , even the bits I manually added.  So its all on the right layer. Just Eagle doesn't seem to want to export them :(

Its causing issues as the place I use for stencils needs the eagle file converting to DXF format, they have a ULP script, but that has the same issue as well.  Its ignores all tcream areas added manually. 

I would have thought Eagle itself would actually export the whole tcream layer as is, I don't get why it doesn't :-(

--
To view any images and attachments in this post, visit:
https://www.element14.com/community/message/224697
Re: tcream layer areas missing [message #170829 is a reply to message #170827] Fri, 23 June 2017 16:38 Go to previous messageGo to next message
Jason Judson
Messages: 4
Registered: June 2017
Junior Member
Which place do you use for stencils? Try this site https://www.oshstencils.com/ , They take eagle brd files or gerbers for the stencils.

--
To view any images and attachments in this post, visit:
https://www.element14.com/community/message/224699
Re: tcream layer areas missing [message #170830 is a reply to message #170829] Fri, 23 June 2017 16:50 Go to previous message
chris swinson
Messages: 4
Registered: October 2016
Junior Member
I was using smtstencil.co.uk , though after chasing my order for 2 months I gave up and ordered from hobbytronics.co.uk. Though they are the ones who need DXF files.

I did not know osh did stencil as well, so thank for that.  Will see if that can get anywhere with them.

--
To view any images and attachments in this post, visit:
https://www.element14.com/community/message/224700
Previous Topic: When I place pads, they're invisible
Next Topic: Any way to change backup file extensions?
Goto Forum:
  


Current Time: Wed Sep 20 09:14:58 GMT 2017