EAGLE Central Forums
Where the EAGLE community meets. Sponsored by Stratford Digital.

Home » CadSoft Support Forums » eagle.userchat.eng » Copy tool loses window focus, requiring two clicks instead of one
Copy tool loses window focus, requiring two clicks instead of one [message #161438] Thu, 18 June 2015 12:00 Go to next message
Andrew Ong
Messages: 1
Registered: June 2015
Junior Member
I have a problem in EAGLE 7.3.0 for OS X. When I use the copy tool in
the schematic editor, the schematic window will lose focus. If I want to
copy an item three times, I would expect to:
1. click copy tool button
2. click item to copy
3. place item on net
4. click "Yes" when EAGLE asks "rename net?"
5. Repeat

But now there is this extra step because EAGLE seems to lose focus on
the window after step 4.

1. click copy tool button
2. click item to copy
3. place item on net
4. click "Yes" when EAGLE asks "rename net?"
5. *Click the the schematic window to get focus*
6. Repeat

This only happens when I have to rename a net and the window pops up. If
no window pops up then the schematic editor does not lose focus. How do
I stop the loss of focus?

--
To view any images and attachments in this post, visit:
http://www.element14.com/community/message/152987
Re: Copy tool loses window focus, requiring two clicks instead of one [message #161704 is a reply to message #161438] Mon, 06 July 2015 09:10 Go to previous message
CadSoft Support
Messages: 538
Registered: September 2006
Senior Member
Am 18.06.2015 um 14:00 schrieb Andrew Ong:
> I have a problem in EAGLE 7.3.0 for OS X. When I use the copy tool in
> the schematic editor, the schematic window will lose focus. If I want to
> copy an item three times, I would expect to:
> 1. click copy tool button
> 2. click item to copy
> 3. place item on net
> 4. click "Yes" when EAGLE asks "rename net?"
> 5. Repeat
>
> But now there is this extra step because EAGLE seems to lose focus on
> the window after step 4.
>
> 1. click copy tool button
> 2. click item to copy
> 3. place item on net
> 4. click "Yes" when EAGLE asks "rename net?"
> 5. *Click the the schematic window to get focus*
> 6. Repeat
>
> This only happens when I have to rename a net and the window pops up. If
> no window pops up then the schematic editor does not lose focus. How do
> I stop the loss of focus?
>
> --
> To view any images and attachments in this post, visit:
> http://www.element14.com/community/message/152987
>

This problem should be solved in the new beta 7.3.2.

http://www.cadsoftusa.com/download-eagle/betatest/


--
Mit freundlichen Gruessen / Best regards
Richard Hammerl
CadSoft Support -- hotline@cadsoft.de
FAQ: http://www.cadsoft.de/training/faq/

Please use the original CadSoft forum at news.cadsoft.de.
Proper posts and reliable file attachments are taken granted.
Previous Topic: "use" libraries
Next Topic: Removing islolation from holes
Goto Forum:
  


Current Time: Thu Mar 23 08:12:41 GMT 2017