EAGLE Central Forums
Where the EAGLE community meets. Sponsored by Stratford Digital.

Home » EAGLE Related Forums, Blogs, ... (Read-Only) » Element 14 :: EAGLE Related Posts » How to fix consistency problems between sch and brd? (Element 14 :: EAGLE Related Posts)
How to fix consistency problems between sch and brd? [message #159261] Fri, 09 January 2015 17:35 Go to next message
messages@element14.co
Messages: 395
Registered: March 2013
Senior Member
I was almost done laying out my board when I tried to fix one of the DRC errors by making a larger thermal pad on a transistor. I changed the selfmade package for this transistor, replaced the transistor symbol in the schematic and thought the corresponding package in the board would update, but it didn't. I had both the schematic window open and the board window open. I think I had another schematic + board open at the same time, but I don't know if that could be the reason why the forward and back annotation failed. I ran the ERC and got the one consistency error shown in the picture below. I have tried a couple of things without sucess:  1. Changed the transistor package back to the original and updated the schematic again.2. Tried to replace the "old" package in the board with the new one. Then I ran the ERC once again and got about 10 new consistency errors. I used the undo and now I am back with the first error shown in the picture. I know that one solution is to delete my layout and make the board all over again, but I really don't want to do that. Is there another way to solve this kind of problems? Thanks a lot! Original article at http://www.element14.com/community/message/136953?tstart=0#136953.

-- Web access to CadSoft support forums at www.eaglecentral.ca. Where the CadSoft EAGLE community meets.
Re: How to fix consistency problems between sch and brd? [message #159451 is a reply to message #159261] Wed, 28 January 2015 22:53 Go to previous message
messages@element14.co
Messages: 395
Registered: March 2013
Senior Member
Hi Simen, In your particular situation, I think the easiest thing to do is remove that one transistor from both the board and the schematic. Once that has been done run the ERC. If consistency has been restored then go ahead and add the transistor. In general it is not a good idea to have multiple instances of EAGLE open at a time, mostly because it can increases the odds of user error. Let me know how this works out. Best Regards,Jorge GarciaCadsoft SupportOriginal article at http://www.element14.com/community/message/138545?tstart=0#138545.

-- Web access to CadSoft support forums at www.eaglecentral.ca. Where the CadSoft EAGLE community meets.
Previous Topic: How to see the added library in ADD window
Next Topic: Group Does Not Work
Goto Forum:
  


Current Time: Sat Jun 24 19:11:40 GMT 2017