EAGLE Central Forums
Where the EAGLE community meets. Sponsored by Stratford Digital.

Home » CadSoft Support Forums » eagle.userchat.eng » Auto-place routine that works?
Auto-place routine that works? [message #158628] Wed, 26 November 2014 20:18 Go to next message
Joerg
Messages: 742
Registered: October 2004
Senior Member
Hello,

Just bought a 7.1 license and taking it for a test drive. I found three
auto-place ULPs in the download section but none of them seems to work.
Maybe because they were for older Eagle versions.

Is there an auto-place routine somewhere that works with V7? Ideally
where one can place critical parts like RF stuff and connectors, then
let the auto-placer drape the rest around.

--
Regards, Joerg

http://www.analogconsultants.com/
Re: Auto-place routine that works? [message #158629 is a reply to message #158628] Wed, 26 November 2014 20:47 Go to previous messageGo to next message
Jorge Garcia
Messages: 1288
Registered: April 2010
Senior Member
On 11/26/2014 3:18 PM, Joerg wrote:
> Hello,
>
> Just bought a 7.1 license and taking it for a test drive. I found three
> auto-place ULPs in the download section but none of them seems to work.
> Maybe because they were for older Eagle versions.
>
> Is there an auto-place routine somewhere that works with V7? Ideally
> where one can place critical parts like RF stuff and connectors, then
> let the auto-placer drape the rest around.
>

Hi Joerg,

We've never run into a good auto-place algorithm either, that's why
we've taken the position to not dedicate developer resources to that.
The ULPs you see are what's available for autoplace.

hth,
Jorge Garcia
Re: Auto-place routine that works? [message #158635 is a reply to message #158629] Thu, 27 November 2014 00:41 Go to previous messageGo to next message
Joerg
Messages: 742
Registered: October 2004
Senior Member
Jorge Garcia wrote:
> On 11/26/2014 3:18 PM, Joerg wrote:
>> Hello,
>>
>> Just bought a 7.1 license and taking it for a test drive. I found three
>> auto-place ULPs in the download section but none of them seems to work.
>> Maybe because they were for older Eagle versions.
>>
>> Is there an auto-place routine somewhere that works with V7? Ideally
>> where one can place critical parts like RF stuff and connectors, then
>> let the auto-placer drape the rest around.
>>
>
> Hi Joerg,
>
> We've never run into a good auto-place algorithm either, that's why
> we've taken the position to not dedicate developer resources to that.
> The ULPs you see are what's available for autoplace.
>

Thanks, Jorge. That's a bit disappointing. However, we shall never give
up so I'll just make a sugestion in the "suggest" forum. After all a
steady vote by some of us for a hierarchy final got us a hierarchy.
Which was the core reason for buying V7 for me because I could not even
properly do one upcoming project without it.

--
Regards, Joerg

http://www.analogconsultants.com/
Re: Auto-place routine that works? [message #166423 is a reply to message #158635] Sat, 30 July 2016 20:00 Go to previous messageGo to next message
9e9v
Messages: 11
Registered: July 2016
Junior Member
Joerg wrote on Thu, 27 November 2014 01:41
Jorge Garcia wrote:
> We've never run into a good auto-place algorithm either, that's why
> we've taken the position to not dedicate developer resources to that.
> The ULPs you see are what's available for autoplace.
>
Thanks, Jorge. That's a bit disappointing. However, we shall never give
up

You misunderstood, there will not be an autoplacer because there is not good solution to the problem.
I have written three ULPs for the task of placing, they are not autoplace programs but they do move parts around due to their connectedness.
They are not in a state to be released but they do kind of work.
If you contact me I am willing to share them with you and explain how to use them.
Re: Auto-place routine that works? [message #167149 is a reply to message #166423] Sat, 17 September 2016 11:53 Go to previous messageGo to next message
9e9v
Messages: 11
Registered: July 2016
Junior Member
Try my ULPs:
Thread
They provide "unpiling".
Re: Auto-place routine that works? [message #167854 is a reply to message #158628] Fri, 18 November 2016 18:22 Go to previous message
Olin
Messages: 903
Registered: December 2009
Location: Massachusetts
Senior Member
Joerg wrote on Wed, 26 November 2014 15:18

Is there an auto-place routine somewhere that works


No. That's the problem. This is not a Eagle-specific issue.

Auto-placing in general is not a solved problem. Some have tried to hack away at it, but as you see, the results aren't impressive.
Previous Topic: how do i find IC in eagle
Next Topic: What revision/version control do you use for EAGLE files?
Goto Forum:
  


Current Time: Mon May 01 00:28:07 GMT 2017