EAGLE Central Forums
Where the EAGLE community meets. Sponsored by Stratford Digital.

Home » CadSoft Support Forums » eagle.betatest » Installing Beta 6.9.1 in MacOS X 10.9
Installing Beta 6.9.1 in MacOS X 10.9 [message #155846] Tue, 17 June 2014 14:50 Go to next message
James Morrison
Messages: 1129
Registered: November 2004
Senior Member

Installing went OK but then when I tried to select the betatest.lic for testing I got an error dialog saying that I needed to run EAGLE as administrator in order to install the license.

I don't recall having to do that in previous versions. And you don't just "run as administrator" in Mac, so that language should be changed.

I was able to get the license installed by using terminal, changing to the new install directory and using the following command:

sudo ./EAGLE\ 6.9.1.app/Contents/MacOS/EAGLE


But I think that should be cleaned up as this is very unusual to have to do in a Mac environment.

James.


James Morrison ~~~ Stratford Digital
http://www.stratforddigital.ca
Re: Installing Beta 6.9.1 in MacOS X 10.9 [message #155871 is a reply to message #155846] Wed, 18 June 2014 11:03 Go to previous messageGo to next message
Walter Spermann
Messages: 540
Registered: August 2010
Senior Member
Hi,
On 06/17/14 16:50, James Morrison wrote:
> Installing went OK but then when I tried to select the betatest.lic for
> testing I got an error dialog saying that I needed to run EAGLE as
> administrator in order to install the license.
>
> I don't recall having to do that in previous versions. And you don't just
> "run as administrator" in Mac, so that language should be changed.
>
> I was able to get the license installed by using terminal, changing to the
> new install directory and using the following command:
>
>
> sudo ./EAGLE\ 6.9.1.app/Contents/MacOS/EAGLE
>
>
> But I think that should be cleaned up as this is very unusual to have to do
> in a Mac environment.
>
> James.
do you have the problem also if you install in a folder owned by you ?
Is it the same if run it as freeware (using it the first time) ?

Regards,
Walter Spermann

--
---------------------------------------------------------------
Walter Spermann
Lead Developer
CadSoft Computer GmbH
Pleidolfweg 15
84568 Pleiskirchen
Tel.: 08635/6989-10
www.cadsoft.de
---------------------------------------------------------------
Registergericht: Amtsgericht Traunstein HRB 5573
Geschäftsführer: Thomas Liratsch
---------------------------------------------------------------
Re: Installing Beta 6.9.1 in MacOS X 10.9 [message #155927 is a reply to message #155871] Fri, 20 June 2014 18:19 Go to previous messageGo to next message
Yu-Hung Lien
Messages: 8
Registered: May 2008
Junior Member
Hi Walter,

I do have the same problem. As in Mac OS X, the default location will be
under /Applications and I believe most of people will not install EAGLE
under his own home directory. BTW, this kind of behaviour did not happen
in previous versions...

Yu-Hung

--
To view any images and attachments in this post, visit:
http://www.element14.com/community/message/117505
Re: Installing Beta 6.9.1 in MacOS X 10.9 [message #155957 is a reply to message #155927] Mon, 23 June 2014 12:10 Go to previous messageGo to next message
Walter Spermann
Messages: 540
Registered: August 2010
Senior Member
Hi,
On 06/20/14 20:19, Yu-Hung Lien wrote:
> Hi Walter,
>
> I do have the same problem. As in Mac OS X, the default location will be
> under /Applications and I believe most of people will not install EAGLE
> under his own home directory. BTW, this kind of behaviour did not happen
> in previous versions...
for MAC OS X 10.8 we had to change the file/directory rights of our deployment to admin
to fix an installation problem under /Applications.
We think this is the reason for that problem and look into it.

Regards,
Walter Spermann
>
> Yu-Hung
>
> --
> To view any images and attachments in this post, visit:
> http://www.element14.com/community/message/117505


--
---------------------------------------------------------------
Walter Spermann
Lead Developer
CadSoft Computer GmbH
Pleidolfweg 15
84568 Pleiskirchen
Tel.: 08635/6989-10
www.cadsoft.de
---------------------------------------------------------------
Registergericht: Amtsgericht Traunstein HRB 5573
Geschäftsführer: Thomas Liratsch
---------------------------------------------------------------
Besuchen Sie uns auf der embedded world!
25.-27. Februar in Nürnberg
Halle 5, Stand 249
Re: Installing Beta 6.9.1 in MacOS X 10.9 [message #156116 is a reply to message #155846] Thu, 03 July 2014 16:04 Go to previous message
Walter Spermann
Messages: 540
Registered: August 2010
Senior Member
On 06/17/14 16:50, James Morrison wrote:
> Installing went OK but then when I tried to select the betatest.lic for
> testing I got an error dialog saying that I needed to run EAGLE as
> administrator in order to install the license.
>
> I don't recall having to do that in previous versions. And you don't just
> "run as administrator" in Mac, so that language should be changed.
>
> I was able to get the license installed by using terminal, changing to the
> new install directory and using the following command:
>
>
> sudo ./EAGLE\ 6.9.1.app/Contents/MacOS/EAGLE
>
>
> But I think that should be cleaned up as this is very unusual to have to do
> in a Mac environment.
>
> James.
Fixed for next beta.

Regards,
Walter Speramnn

--
---------------------------------------------------------------
Walter Spermann
Lead Developer
CadSoft Computer GmbH
Pleidolfweg 15
84568 Pleiskirchen
Tel.: 08635/6989-10
www.cadsoft.de
---------------------------------------------------------------
Registergericht: Amtsgericht Traunstein HRB 5573
Geschäftsführer: Thomas Liratsch
---------------------------------------------------------------
Previous Topic: Hierarchy issue - Deleting a non-existing port causes the port to be added
Next Topic: New icons...
Goto Forum:
  


Current Time: Wed Sep 20 12:43:49 GMT 2017