EAGLE Central Forums
Where the EAGLE community meets. Sponsored by Stratford Digital.

Home » EAGLE Related Forums, Blogs, ... (Read-Only) » Element 14 :: EAGLE Related Posts » Bug: Fenster Fokus mit 6.5.x auf Mac OS X (Element 14 :: EAGLE Related Posts)
Bug: Fenster Fokus mit 6.5.x auf Mac OS X [message #155432] Mon, 19 May 2014 11:11 Go to next message
messages@element14.co
Messages: 392
Registered: March 2013
Senior Member
Hi, ich verwende Eagle 6.5.0 auf Mac OS X 10.9. Seit Version 6 ist das Fokus-Verhalten kaputt, so das der Fokus auf sch oder pcb verloren ist, sobald ein dialog aufgepoppt ist, z.B. bei 'add'.Auswirkung: Ctrl-Click zum drehen der Bauteile klappt nicht, man muss erst auf das Sch-Fenster Klicken. Gewünschtes Verhalten: Wenn ein Dialog geöffnet wird, soll der Fokus zuverlässig zurück auf das Fenster, von dem man gekommen ist gehen.z.B. wenn ich im Schaltplan per 'add' ein Bauteil hinzufüge und im Dialog OK klicke, soll das Sch-Fenster wieder den Fokus haben. Danke im Voraus für einen baldigen fix, das ist eine äußerst ärgerliches Problem, speziell wenn man mit dem Touchpad arbeitet. Grüße,  - pitOriginal article at http://www.element14.com/community/message/113181?tstart=0#113181.

-- Web access to CadSoft support forums at www.eaglecentral.ca. Where the CadSoft EAGLE community meets.
Re: Bug: Fenster Fokus mit 6.5.x auf Mac OS X [message #155544 is a reply to message #155432] Mon, 26 May 2014 08:12 Go to previous messageGo to next message
messages@element14.co
Messages: 392
Registered: March 2013
Senior Member
Hallo, das kann ich hier am Mac Mini mit OSX 10.9 nicht nachvollziehen. Egal welches Dialog-Fenster geöffnet wird, ich komme immer wieder in das entsprechende Editor-Fenster zurück. Könnten Sie die Vorgehensweise ganz genau beschreiben? Grüße,Richard HammerlOriginal article at http://www.element14.com/community/message/114078?tstart=0#114078.

-- Web access to CadSoft support forums at www.eaglecentral.ca. Where the CadSoft EAGLE community meets.
Re: Bug: Fenster Fokus mit 6.5.x auf Mac OS X [message #155632 is a reply to message #155432] Sun, 01 June 2014 18:32 Go to previous messageGo to next message
messages@element14.co
Messages: 392
Registered: March 2013
Senior Member
Danke für die Antwort. Ich habe eine Demonstration hier aufgezeichnet: https://dl.dropboxusercontent.com/u/17258460/Eagle%20Bug.mov Passiert immer, wenn ein Dialog involviert ist und man nicht danach z.B. einen neuen Befehl anklickt. (Ich tippe die Befehle ein, geht für mich schneller).Problem besteht identisch in Sch und Brd.Wie sie sehen, muss ich immer auf z.B. die Titelleiste des Fensters klicken, damit der Editor wieder "richtig" den Fokus bekommt.Grüße, - pitOriginal article at http://www.element14.com/community/message/114810?tstart=0#114810.

-- Web access to CadSoft support forums at www.eaglecentral.ca. Where the CadSoft EAGLE community meets.
Re: Bug: Fenster Fokus mit 6.5.x auf Mac OS X [message #155693 is a reply to message #155432] Wed, 04 June 2014 11:47 Go to previous messageGo to next message
messages@element14.co
Messages: 392
Registered: March 2013
Senior Member
Hallo, ich kann das Problem hier nicht nachvollziehen.... Welches Mavericks ist es denn genau? 10.9.2 oder 10.9.3? MfG,Richard HammerlOriginal article at http://www.element14.com/community/message/115180?tstart=0#115180.

-- Web access to CadSoft support forums at www.eaglecentral.ca. Where the CadSoft EAGLE community meets.
Re: Bug: Fenster Fokus mit 6.5.x auf Mac OS X [message #155717 is a reply to message #155432] Thu, 05 June 2014 08:06 Go to previous messageGo to next message
messages@element14.co
Messages: 392
Registered: March 2013
Senior Member
Ich mache immer jedes Update, Aktuell nutze ich 10.9.3. Das Problem besteht aber schon mindestens seit 10.7.Original article at http://www.element14.com/community/message/115334?tstart=0#115334.

-- Web access to CadSoft support forums at www.eaglecentral.ca. Where the CadSoft EAGLE community meets.
Re: Bug: Fenster Fokus mit 6.5.x auf Mac OS X [message #156989 is a reply to message #155432] Fri, 15 August 2014 19:44 Go to previous messageGo to next message
messages@element14.co
Messages: 392
Registered: March 2013
Senior Member
Das scheint verknüpfelt mit meinem Problem http://www.element14.com/community/message/123191/l/mittlere-maustaste-in-osx#123191 zu sein. Da ich dort seit jetzt 8 Tagen keine Antwort oder Nachfrage bekommen habe, hänge ich mich mal hier an... Für mich insbesondere nervig ist, dass das Verschieben des Blattes mit der mittleren Maustaste nicht mehr richtig funktioniert. Klickt man mit der mittl. MT um das Blatt zu verschieben, springt es an eine unvorhersehbare Stelle und man ist total desorientiert. Das ist mMn seit Version 6.0 so, wobei ich exakt diese Version nie installiert hatte. z.Zt. benutze ich Version 6.6. Ich kann nicht sagen, ob es erst seit Mavericks so ist, (ich hatte zwischendurch eine längere Eagle-Benutzungspause) ich glaube aber eher, dass es an der Eagle-Version liegt. Vermutl. wurde mit Version 6 auf eine neuere Version von Qt gewechselt, also vermutlich von 4.8 auf 5.x. Das hat auch mir sehr viel Freude bereitet... Ich möchte nochmal unterstreichen, dass das arbeiten unter OSX mit Eagle z.Zt. extrem nervig ist. Ich habe mich deshalb schon nach Alternativen umgesehen. Ich benutze aber die Hobbyisten-Version (da rein privates Vergnügen) und da sind die Alternativen eher Freeware und da vor Allem unter Linux. Wenn ich mir das antue, kann ich vermutlich dort Eagle wieder benutzen. mfG. G. WoigkOriginal article at http://www.element14.com/community/message/123842?tstart=0#123842.

-- Web access to CadSoft support forums at www.eaglecentral.ca. Where the CadSoft EAGLE community meets.
Re: Bug: Fenster Fokus mit 6.5.x auf Mac OS X [message #157045 is a reply to message #155432] Mon, 18 August 2014 16:38 Go to previous messageGo to next message
messages@element14.co
Messages: 392
Registered: March 2013
Senior Member
Richard Hammerl schrub in Mittlere Maustaste in OSX:
ich habe an meinem Mac-Mini eine Logitech-Maus dran. Mit der
funktioniert die mittlere Maustaste ganz normal.
EAGLE 6.6.0 und OSX 10.9.....
 Irgendwo müssen wir da einen Unterschied haben... Ich habe einen iMac und OSX 10.9.4 und z.Zt. Eagle 6.6.Das war aber auch schon in 6.4 (?) so (hatte ich in der Free-Version installiert, um eine Eagle-Datei aus dem Netz anzuschauen, was aber mit dem Mac nicht funktionierte) und vermutlich noch OSX10.8 so. Frühere Versionen von 6.x als 6.4 hatte ich nie installiert.Ich habe auch eine Logitech-Maus dran. Ich vermute, dass es wie von 0xPIT beobachtet am Fenster-Fokus liegt. Nach der Beschreibung von 0xPIT konnte ich das auch bei mir so eingrenzen. Man macht ein Popup auf und danach hat das Hauptfenster keinen Fokus mehr. Resultat: Keine Voransicht beim Verschieben von Bauteilen und beim Klicken mit der mittl. MT springt das Bild zu einer erratischen Position. Vorgehen: (1) Eagle startenneues Board anlegeneine Box zeichnen o.Ä., nur zur OrientierungKlick auf Grid-Einstellungen-Knopfgleich wieder schließenmit der mittl. MT im Bild eher rechts-unten Klicken zum Verschieben=> Bild springt, die gerade gezeichnete Box ist komplett aus dem Bildschirm verschwunden. (2) Eagle startenneues Board anlegeneine Box zeichnen o.Ä., nur zur OrientierungKlick auf Grid-Einstellungen-Knopfgleich wieder schließenauf die Fensterleiste klickenmit der mittl. MT im Bild eher rechts-unten Klicken zum Verschieben=> Bild lässt sich wie erwartet verschieben. Wenn Sie das so immer noch nicht nachvollziehen können, müssen Sie mir gezielte Fragen stellen, um die entscheidenden Unterschiede herauszufinden.  mfG. G. WoigkOriginal article at http://www.element14.com/community/message/124026?tstart=0#124026.

-- Web access to CadSoft support forums at www.eaglecentral.ca. Where the CadSoft EAGLE community meets.
Re: Bug: Fenster Fokus mit 6.5.x auf Mac OS X [message #157309 is a reply to message #155432] Thu, 04 September 2014 13:21 Go to previous message
messages@element14.co
Messages: 392
Registered: March 2013
Senior Member
Gehe ich recht in der Annahme, dass das wohl nicht gefixt wird? mfG. G. WoigkOriginal article at http://www.element14.com/community/message/125635?tstart=0#125635.

-- Web access to CadSoft support forums at www.eaglecentral.ca. Where the CadSoft EAGLE community meets.
Previous Topic: PIC18F4431-E/PT error in Library: Wrong Version
Next Topic: BB View 7" xbmc
Goto Forum:
  


Current Time: Sat May 27 00:34:11 GMT 2017