EAGLE Central Forums
Where the EAGLE community meets. Sponsored by Stratford Digital.

Home » CadSoft Support Forums » eagle.suggest.eng » error message: Package variant already defined! - but if it is, I sure can't find it!!!
error message: Package variant already defined! - but if it is, I sure can't find it!!! [message #154341] Thu, 13 March 2014 20:32 Go to next message
Dave Nelson
Messages: 2
Registered: March 2014
Junior Member
Hey team, sorry for a rookie question...

I'm trying to use a 2N2222 with a TO92 package.  The only package that's
in the library appears to be a TO18.  When I try to add a new package, I
get the error message "Package variant already defined!"...

If there's a 2N2222 with a TO92 package in the library, I sure as heck
can't find it.  What stupid mistake am I making this time?

THANKS!

--
To view any images and attachments in this post, visit:
http://www.element14.com/community/message/106212
Re: error message: Package variant already defined! - but if it is, I sure can't find it!!! [message #154355 is a reply to message #154341] Fri, 14 March 2014 05:22 Go to previous messageGo to next message
Joern Paschedag
Messages: 1429
Registered: August 2008
Senior Member
Am 13.03.2014 21:54, schrieb Dave Nelson:
> Hey team, sorry for a rookie question...
>
> I'm trying to use a 2N2222 with a TO92 package. The only package that's
> in the library appears to be a TO18.

What means "appears"?
Go to board and "ADD" from the library you have found the 2N2222 then
you will see the packages in the library. ;-)

That goes with control panel as well.

When I try to add a new package, I
> get the error message "Package variant already defined!"...
>
> If there's a 2N2222 with a TO92 package in the library, I sure as heck
> can't find it. What stupid mistake am I making this time?


Most likely the 2n2222 is defined with a TO18 package only in the
LIBRARY. So you must open the library and add a new package to the
2N2222 device.

Generally you should do that with your own library.

--
Mit freundlichen Grüßen / With best regards

Joern Paschedag
Re: error message: Package variant already defined! - but if it is, I sure can't find it!!! [message #154358 is a reply to message #154341] Fri, 14 March 2014 05:58 Go to previous messageGo to next message
Lorenz
Messages: 643
Registered: December 2006
Senior Member
Dave Nelson wrote:

>Hey team, sorry for a rookie question...

no sweat, everyone was a rookie once 8-)


>I'm trying to use a 2N2222 with a TO92 package.  The only package that's
>in the library appears to be a TO18.  When I try to add a new package, I
>get the error message "Package variant already defined!"...
>[...]

ok, so your are in the library editor and trying to add an additional
package.

look to the right side of the editor window. There is a listing of the
already present packages. First column: package name, second column:
VARIANT, third column: check mark if pin-pad connections are already
in placs.

If you want to have multiple packages in a device, you need to give
them unique variant names.

as with technologies, this variant name will be attachted to the
device name. Either in the form <devicename><technology><variant>, or
you can place a '*' for technology and '?' for pachage in the device
name if you a´want a different arrangement.
--

Lorenz
Re: error message: Package variant already defined! - but if it is, I sure can't find it!!! [message #154372 is a reply to message #154358] Fri, 14 March 2014 12:02 Go to previous messageGo to next message
Dave Nelson
Messages: 2
Registered: March 2014
Junior Member
Hey, many thanks to CadSoft Guest!  Issue was simply that I needed to
create a new variant name.  Well done, Sir!

--
To view any images and attachments in this post, visit:
http://www.element14.com/community/message/106289
Re: error message: Package variant already defined! - but if it is, I sure can't find it!!! [message #165953 is a reply to message #154341] Fri, 03 June 2016 15:58 Go to previous messageGo to next message
Stephen Denis
Messages: 4
Registered: November 2015
Junior Member
Call me stupid, if you want!

Why, if a package name is listed, can you not link to that package? It seems ludicrous that, for every part that I need to add an additional package, I have to create a new package name for something that already exist?

I am still not able to get the 'add variant' thing to work. I just either just add a whole new copy of the component, with the new package, or I choose a component that already fits the package and make notes about the substitution.

Yes, it may be a stupid way to do it. But, explain to me why making an additional X number of names of an existing Y number of components, by different names, is more efficient?

I should be able to just Click Add, Choose a Package, and Click Done. If the Package does not exist, then I am off to edit a new package.

--
To view any images and attachments in this post, visit:
https://www.element14.com/community/message/198709
Re: error message: Package variant already defined! - but if it is, I sure can't find it!!! [message #165970 is a reply to message #165953] Sun, 05 June 2016 19:55 Go to previous messageGo to next message
Olin
Messages: 903
Registered: December 2009
Location: Massachusetts
Senior Member
Stephen Denis wrote on Fri, 03 June 2016 11:58

Why, if a package name is listed, can you not link to that package?


What editor are you in. "Listed" where exactly. What do you mean "link to". Are you trying to add a package to a existing device? Is that package already in the library that the device is in?

Quote:

It seems ludicrous that, ...

Ah, so this is a rant, not really a question. I was going to try to help, but I'm not going to read a rant. Tuning out.
Re: error message: Package variant already defined! - but if it is, I sure can't find it!!! [message #165971 is a reply to message #165953] Mon, 06 June 2016 05:05 Go to previous messageGo to next message
Lorenz
Messages: 643
Registered: December 2006
Senior Member
Stephen Denis wrote:
> Call me stupid, if you want!
> [...]

have you even read the previous postings in this thread?
--

Lorenz
Re: error message: Package variant already defined! - but if it is, I sure can't find it!!! [message #168043 is a reply to message #154341] Mon, 12 December 2016 22:29 Go to previous messageGo to next message
Sean Org
Messages: 1
Registered: December 2016
Junior Member
*Ho come on this one is simple*

Just open the Library editor
-Open the device you want to add variant to
-On the top left you will see the picture of the other variant
-Below you will see list of all the variants one column says PACKAGE the next problematic one says VARIANT
-Now look for this symbol "" that mean someone forgot to add a unique name , right click , and select rename call it anything you want
-Now you can add your new variant will ease . 

tag this post with positive rating so other will  find this answer quicker  and skip the spam

Sincerely Sean
who got the same stupid problem

--
To view any images and attachments in this post, visit:
https://www.element14.com/community/message/210982
Re: error message: Package variant already defined! - but if it is, I sure can't find it!!! [message #170045 is a reply to message #168043] Tue, 14 March 2017 11:53 Go to previous message
Brad Bartley
Messages: 6
Registered: October 2015
Junior Member
I believe this was the actual correct answer (at least to the problem I was having). Too bad the bozo who didn't assign a variant name was me. Thank you!

--
To view any images and attachments in this post, visit:
https://www.element14.com/community/message/218347
Previous Topic: Cannot move groups
Next Topic: Profile based human proximity sensor
Goto Forum:
  


Current Time: Sun May 28 02:53:35 GMT 2017