EAGLE Central Forums
Where the EAGLE community meets. Sponsored by Stratford Digital.

Home » CadSoft Support Forums » eagle.support.ger » Eagle-lib Kompatibilität
Eagle-lib Kompatibilität [message #152114] Thu, 22 August 2013 15:30 Go to next message
Steven Anstett
Messages: 3
Registered: August 2013
Junior Member
Hallo,

ich benutze aktuell die 6.4er Version und habe haufenweise libs die mit
älteren Versionen erstellt wurden.
Wenn ich jetzt so eine ältere lib mit der 6.4er aufmachen möchte, öffnet
er mir die lib nur in einer Textdatei.
In der 5.1er Version funktioniert die lib aber problemlos.

Wie kann ich ältere libs auf die neuste Eagle-Version kompatibel
machen???

Danke, vorab!

Grüße
Steven

--
Um alle Bilder und Anhänge in diesem Beitrag zu sehen, besuchen Sie:
http://www.element14.com/community/message/87354#87354
Re: Eagle-lib Kompatibilität [message #152121 is a reply to message #152114] Fri, 23 August 2013 06:48 Go to previous messageGo to next message
A. Zaffran
Messages: 2532
Registered: November 2008
Senior Member
Am 22.08.2013 17:40, schrieb Steven Anstett:
> Hallo,
>
> ich benutze aktuell die 6.4er Version und habe haufenweise libs die mit
> älteren Versionen erstellt wurden.
> Wenn ich jetzt so eine ältere lib mit der 6.4er aufmachen möchte, öffnet
> er mir die lib nur in einer Textdatei.

Es werden zwei Textfenster geöffnet.
1. Der Fehler-Report .lbr.rpt
Ohne Kenntnis dieser Meldung kann man nichts sagen.

2. Die konvertierte LBR im XML-Format .rpt.lbr

Im 1. Textfenster steht die Meldung, mit der Zeilen-Nummer in der
der Fehler aufgetreten ist.
***
Wechseln sie in das Fenster der .rpt.lbr, drücken Sie CTRL+L,
geben Sie die Zeilennummer aus dem 1. Text-Fenster ein, und
berichtigen Sie entsprechende Stelle.


> In der 5.1er Version funktioniert die lib aber problemlos.

Weil bis V5 ein binäres Datenformat benutzt wurde, und da werden
nur Bits/Bytes behandelt, die eine Behandlung bedürfen.
Für V6 muß die komplette Datei zuerst in das XML-Format konvertiert
werden, und dann vom XML-Parser gelesen. Dabei kommt es zu evtl.
Meldungen, sofern aus der Sicht des Parser Fehler enthalten sind.

Mögliche "alte" mitgeschleppte Fehler sind z.B. ein Pin/Pad-Name
der Leer ist, also name="". Vermutlich handelt es sich um einen
Fehler, der schon über mehrere Eagle-Versionen mitgeschleppt wurde,
vermutlich aus V3.5 oder noch älter.


>
> Wie kann ich ältere libs auf die neuste Eagle-Version kompatibel
> machen???

Siehe ***


***
Um das Original zu lesen, und auch zuverlässig angehängte Dateien
bereitstellen zu können, benutzen Sie news.cadsoft.de und einen
funktionierenden News-Reader wie Thunderbird!
***

Mit freundlichen Grüßen / Best regards

Alfred Zaffran
--
______________________________________________________________
Alfred Zaffran Support
CadSoft Computer GmbH Hotline: 08635-698930
Pleidolfweg 15 FAX: 08635-698940
84568 Pleiskirchen eMail: <alf@cadsoft.de>
Web: <www.cadsoft.de>
Registergericht: Amtsgericht Traunstein HRB 5573
Geschäftsführer: Thomas Liratsch
______________________________________________________________
*EAGLE V6.4 availabe now!*
Re: Eagle-lib Kompatibilität [message #171324 is a reply to message #152121] Tue, 15 August 2017 12:04 Go to previous messageGo to next message
Steven Anstett
Messages: 3
Registered: August 2013
Junior Member
Erneut das gleiche Problem. Mit dem Workaround von oben komm ich leider nicht mehr weiter. Die nachträglichen Änderung bleiben nur vorläufig. Bei erneutem öffnen sind die Fehler wieder da.

--
Um alle Bilder und Anhänge in diesem Beitrag zu sehen, besuchen Sie:
https://www.element14.com/community/message/227203
Re: Eagle-lib Kompatibilität [message #171351 is a reply to message #152114] Wed, 16 August 2017 06:35 Go to previous messageGo to next message
Joern Paschedag
Messages: 1455
Registered: August 2008
Senior Member
Am 22.08.2013 um 17:40 schrieb Steven Anstett:
> Hallo,
>
> ich benutze aktuell die 6.4er Version und habe haufenweise libs die mit
> älteren Versionen erstellt wurden.
> Wenn ich jetzt so eine ältere lib mit der 6.4er aufmachen möchte, öffnet
> er mir die lib nur in einer Textdatei.
> In der 5.1er Version funktioniert die lib aber problemlos.
>
> Wie kann ich ältere libs auf die neuste Eagle-Version kompatibel
> machen???
>
> Danke, vorab!
>
> Grüße
> Steven
>
> --
> Um alle Bilder und Anhänge in diesem Beitrag zu sehen, besuchen Sie:
> http://www.element14.com/community/message/87354#87354
>

Wenn eine ältere lib nicht mit einer neueren Version geöffnet werden
kann, dann ist gewöhnlich etwas anderes faul. Ich würde "alte" libs auch
nicht einfach so auf neu konvertieren, sondern eine Copy davon. Da du
noch von einer 5-er Version redest kannst du mit der keine 6-er öffnen.
Ich nehme auch an, du redest von eigenen libs, denn neuere Versionen
schleppen "den alten Kram" ;-) immer noch mit.
Ich würde dir auch raten, deine 5.1 Version auf 5.12 zu updaten,
gleiches von 6.4 auf 6.6.
Das sind jeweils die letzten Versionen. Das kostet dich nix, deine
Lizenzen lassen das zu.
Wenn du beide Versionen parallel betreiben willst, musst du dich mit dem
U-Parameter befassen, der eine Namensgebung und beliebige Pfadangabe der
"eaglerc.usr" zu lässt.
Info über diesen Parameter findest du im doc Unterverzeichnis/
update_de.txt unter "Verschiedenes".

Wenns kein Staatsgeheimnis ist kannst du mir auch mal deine defekte(n)
libs zuschicken und ich schau mal, ob ich den Wurm finde...

--
Mit freundlichen Grüßen / With best regards

Joern Paschedag
Re: Eagle-lib Kompatibilität [message #171392 is a reply to message #171351] Fri, 18 August 2017 10:17 Go to previous messageGo to next message
Steven Anstett
Messages: 3
Registered: August 2013
Junior Member
nach langer klickerei schließlich doch hinbekommen.
trotzdem vielen dank, für die angebotene Hilfe.

--
Um alle Bilder und Anhänge in diesem Beitrag zu sehen, besuchen Sie:
https://www.element14.com/community/message/227309
Re: Eagle-lib Kompatibilität [message #171488 is a reply to message #171324] Mon, 28 August 2017 15:15 Go to previous message
cadsoft[1]
Messages: 24
Registered: February 2017
Junior Member
Am 15.08.2017 um 14:04 schrieb Steven Anstett:
> Erneut das gleiche Problem. Mit dem Workaround von oben komm ich leider nicht mehr weiter. Die nachträglichen Änderung bleiben nur vorläufig. Bei erneutem öffnen sind die Fehler wieder da.
>
> --
> Um alle Bilder und Anhänge in diesem Beitrag zu sehen, besuchen Sie:
> https://www.element14.com/community/message/227203
>

Wo ist denn Dein Ursprungsbeitrag?
Grüße
Christoph
Previous Topic: Transistor PIN lässt sich nicht routen
Next Topic: Suche Bauteil Zenerdiode BZV55
Goto Forum:
  


Current Time: Fri Sep 22 20:41:25 GMT 2017