EAGLE Central Forums
Where the EAGLE community meets. Sponsored by Stratford Digital.

Home » CadSoft Support Forums » eagle.userchat.eng » version 6.4 LTspice schematic importing into EAGLE
version 6.4 LTspice schematic importing into EAGLE [message #148880] Tue, 08 January 2013 15:34 Go to next message
Tronicus
Messages: 3
Registered: February 2012
Junior Member
I've just been reading the release notes on EAGLE 6.4 and read you can import LTspice Schematics into EAGLE.

This is great, as I tend to use LTspice alot for simulating circuits.

However, when i try to impotr the .asc LTSpice schematic file I get an error window pop-up:

*Eagle: import-accel.ulp*

*Wrong file signature: Version*

*<pressed ok>*

Followed by:

*Error:*

*Can't find ' <insert directory here>\<LTspice schematic name>.scr'*

which to me sound like your supposed to export something from LTSpice, which spits out a script file to run in EAGLE.

Can't find anything in LTspice that does this so am a bit stumped.

Can anyone help?
*
*
Re: version 6.4 LTspice schematic importing into EAGLE [message #148902 is a reply to message #148880] Wed, 09 January 2013 14:11 Go to previous messageGo to next message
richard chapman
Messages: 2
Registered: January 2013
Junior Member
I've had a bit more uck that you.
I'm not sure about the first error - but I think you are misinterpreting the seond error. I think Eagle creates the scr file as an intermediate script file while doing the import.
In my case - I had some permissions problems while Eagle tried to generate the "scr" file.
You can either change the folder where it writes the scr file - or run eagle "as administrator" in windows 7 so it breates the scr file without problems.

I really don't know what caused your first error. I didn;t see that.

I found this section helpful:
http://www.cadsoftusa.com/services/simulation/
Though I think the "ulp" is now included in V6.4.

Richard.
Re: version 6.4 LTspice schematic importing into EAGLE [message #168850 is a reply to message #148880] Mon, 23 January 2017 16:21 Go to previous messageGo to next message
Joshua White
Messages: 1
Registered: January 2017
Junior Member
I'm getting the same errors as Tronicus:

+*Eagle: import-accel.ulp*+
++
+*Wrong file signature: Version*+
++
+*<pressed ok>*+
++
+Followed by:+
++
+*Error:*+
++
+*Can't find ' <insert directory here>\<LTspice schematic name>.scr'*+



Any help?!

-JW

--
To view any images and attachments in this post, visit:
https://www.element14.com/community/message/213933
Re: version 6.4 LTspice schematic importing into EAGLE [message #168867 is a reply to message #168850] Mon, 23 January 2017 22:36 Go to previous message
Jorge Garcia
Messages: 1294
Registered: April 2010
Senior Member
On 1/23/2017 11:21 AM, Joshua White wrote:
> I'm getting the same errors as Tronicus:
>
> +*Eagle: import-accel.ulp*+
> ++
> +*Wrong file signature: Version*+
> ++
> +*<pressed ok>*+
> ++
> +Followed by:+
> ++
> +*Error:*+
> ++
> +*Can't find ' <insert directory here>\<LTspice schematic name>.scr'*+
>
>
>
> Any help?!
>
> -JW
>
> --
> To view any images and attachments in this post, visit:
> https://www.element14.com/community/message/213933
>
Hello Joshua,

I hope you're doing well. You are using the wrong ULP, you need to use
the LTSpice ulp, it has an icon in the top right where you can import
your LTSpice schematic from.

Currently this feature is Windows only although some work has been done
to port it over to Linux and Mac. This work is still ongoing.

Let me know if there's anything else I can do for you.

Best Regards,
Jorge Garcia
Previous Topic: Change to v8 Standard License
Next Topic: EAGLE V8.0 Change Log
Goto Forum:
  


Current Time: Sun Jun 25 12:08:59 GMT 2017