EAGLE Central Forums
Where the EAGLE community meets. Sponsored by Stratford Digital.

Home » CadSoft Support Forums » eagle.userchat.ger » Device mit mehreren Gates
Device mit mehreren Gates [message #146186] Fri, 01 June 2012 06:49 Go to next message
Matthias Kirchner
Messages: 19
Registered: May 2006
Junior Member
Hallo miteinander!

Ich habe ein kleines Problem bei der Erstellung eines Device mit mehreren
Gates. Bisher habe ich das immer so hinbekommen wie ich wollte, diesmal nicht.

Das Device soll aus insgesamt 9 Gates bestehen. Dabei ist eines das mit den
Versorgungspins, denen habe ich Addlevel "Request" verpasst. Damit verhalten
sie sich so wie gewünscht ("Reinholen" nach Bedarf).
Bei den anderen Gates krige ich nicht die richtigen Addlevel hin, und zwar
soll folgendes passieren:
Man klickt im Schaltplaneditor auf Add, wählt das Device und es kommt das
erste Funktionsgate - und NUR dieses. Dieses ist wichtig und MUSS da sein,
deswegen habe ich mit MUST und ALWAYS probiert. Wenn man das Gate platziert
hat, kommt das zweite Funktionsgate, das Dritte usw. - diese müssen aber nicht
da sein, auch das Zweite schon nicht.

Ich habe mit diversen Kombinationen aus verschiedenen Addlevels
experimentiert, aber irgendwie gelingt es nicht. Ich kriege entweder immer das
MUST-Gate UND das Zweite Funktions-Gate oder mit jedem Add ein neues IC, also
immer NUR die MUST-Gates. Beides doof.

Wie muss ich die Addlevel einstellen?

TIA
Matthias
Re: Device mit mehreren Gates [message #146188 is a reply to message #146186] Fri, 01 June 2012 08:35 Go to previous messageGo to next message
Joern Paschedag
Messages: 1429
Registered: August 2008
Senior Member
Am 01.06.2012 08:49, schrieb Matthias Kirchner:
> Hallo miteinander!
>
> Ich habe ein kleines Problem bei der Erstellung eines Device mit mehreren
> Gates. Bisher habe ich das immer so hinbekommen wie ich wollte, diesmal nicht.
>
> Das Device soll aus insgesamt 9 Gates bestehen. Dabei ist eines das mit den
> Versorgungspins, denen habe ich Addlevel "Request" verpasst. Damit verhalten
> sie sich so wie gewünscht ("Reinholen" nach Bedarf).
> Bei den anderen Gates krige ich nicht die richtigen Addlevel hin, und zwar
> soll folgendes passieren:
> Man klickt im Schaltplaneditor auf Add, wählt das Device und es kommt das
> erste Funktionsgate - und NUR dieses. Dieses ist wichtig und MUSS da sein,
> deswegen habe ich mit MUST und ALWAYS probiert. Wenn man das Gate platziert
> hat, kommt das zweite Funktionsgate, das Dritte usw. - diese müssen aber nicht
> da sein, auch das Zweite schon nicht.
>
> Ich habe mit diversen Kombinationen aus verschiedenen Addlevels
> experimentiert, aber irgendwie gelingt es nicht. Ich kriege entweder immer das
> MUST-Gate UND das Zweite Funktions-Gate oder mit jedem Add ein neues IC, also
> immer NUR die MUST-Gates. Beides doof.
>
> Wie muss ich die Addlevel einstellen?
>
> TIA
> Matthias

Addlevel ist NEXT. Warum öffnest du nicht eine library z.B. ein 7400 und
schaust wie es dort gemacht ist?

--
Mit freundlichen Grüßen / With best regards

Joern Paschedag
Re: Device mit mehreren Gates [message #146190 is a reply to message #146188] Fri, 01 June 2012 10:26 Go to previous message
Matthias Kirchner
Messages: 19
Registered: May 2006
Junior Member
>> Ich habe ein kleines Problem bei der Erstellung eines Device mit mehreren
>> Gates. Bisher habe ich das immer so hinbekommen wie ich wollte,
>> diesmal nicht.
>> ...
>> Wie muss ich die Addlevel einstellen?
>>

> Addlevel ist NEXT. Warum öffnest du nicht eine library z.B. ein 7400 und
> schaust wie es dort gemacht ist?
>


Genau das habe ich gemacht. In einem 7400 beispielsweise gibt es aber keine
MUST-Gates. Wenn ich die "optionalen" Gates auf NEXT stelle, kommen beim ADD
immer das MUST-Gate _und_ das erste NEXT-Gate. Gerade das wollte ich nicht,
denn bereits das erste optionale ist eben optional ;-)
Wie gesagt:

>> Man klickt im Schaltplaneditor auf Add, wählt das Device und es kommt das
>> erste Funktionsgate - und NUR dieses. Dieses ist wichtig und MUSS da sein

Matthias
Previous Topic: ESD-Symbol
Next Topic: alte 7-Segment LED
Goto Forum:
  


Current Time: Sat May 27 13:51:11 GMT 2017