EAGLE Central Forums
Where the CadSoft EAGLE community meets.

Home » CadSoft Support Forums » eagle.support.eng » ERC Warning: No pins on net N$XX - can't find net N$XX
ERC Warning: No pins on net N$XX - can't find net N$XX [message #125842] Mon, 10 May 2010 10:01 Go to next message
J_ADT
Messages: 13
Registered: January 2008
Junior Member
Hi,

I'm getting an ERC Warning in the schematic editor: 'No pins on net
N$XX' - there's 4 instances of this for 4 different nets.

I've tried SHOW, RUN FIND and Export Net List - but none of the nets
are showing up.

Since this warning only showed up this morning - I've gone back and
'hand-checked' the work I've done, but still no luck.

Any clues as to how to find/fix these supposed non-connected nets?

Many thanks.

J
Re: ERC Warning: No pins on net N$XX - can't find net N$XX [message #125877 is a reply to message #125842] Tue, 11 May 2010 03:52 Go to previous messageGo to next message
Richard Hammerl
Messages: 2512
Registered: October 2004
Senior Member
J_ADT schrieb:
> Hi,
>
> I'm getting an ERC Warning in the schematic editor: 'No pins on net
> N$XX' - there's 4 instances of this for 4 different nets.
>
> I've tried SHOW, RUN FIND and Export Net List - but none of the nets are
> showing up.
>
> Since this warning only showed up this morning - I've gone back and
> 'hand-checked' the work I've done, but still no luck.
>
> Any clues as to how to find/fix these supposed non-connected nets?
>
> Many thanks.

Suppose you are working with EAGLE 5. Try

SHOW @ N$xxx

Does EAGLE show you the net now?


--
Mit freundlichen Gruessen / Best regards
Richard Hammerl
CadSoft Support -- hotline@cadsoft.de
FAQ: http://www.cadsoft.de/faq.htm
Re: ERC Warning: No pins on net N$XX - can't find net N$XX [message #125886 is a reply to message #125877] Tue, 11 May 2010 09:13 Go to previous messageGo to next message
J_ADT
Messages: 13
Registered: January 2008
Junior Member
On 2010-05-11 08:52:17 +0100, Richard Hammerl <ric@cadsoft.de> said:

> J_ADT schrieb:
>> Hi,
>>
>> I'm getting an ERC Warning in the schematic editor: 'No pins on net
>> N$XX' - there's 4 instances of this for 4 different nets.
>>
>> I've tried SHOW, RUN FIND and Export Net List - but none of the nets are
>> showing up.
>>
>> Since this warning only showed up this morning - I've gone back and
>> 'hand-checked' the work I've done, but still no luck.
>>
>> Any clues as to how to find/fix these supposed non-connected nets?
>>
>> Many thanks.
>
> Suppose you are working with EAGLE 5. Try
>
> SHOW @ N$xxx
>
> Does EAGLE show you the net now?

Hi Richard, thanks for the reply.

I've just opened up the file, done an ERC - and those Warnings from
yesterday have all dissapeared.

Very strange, but I'll consider it fixed for now! Thanks for your
suggestion - if it comes up again I'll try it.

J
Re: ERC Warning: No pins on net N$XX - can't find net N$XX [message #125897 is a reply to message #125886] Wed, 12 May 2010 02:36 Go to previous message
Morten Leikvoll
Messages: 932
Registered: November 2007
Senior Member
"J_ADT" <info@spam.com> wrote in message
news:hsbl52$aoa$1@cheetah.cadsoft.de...
> I've just opened up the file, done an ERC - and those Warnings from
> yesterday have all dissapeared.
>
> Very strange, but I'll consider it fixed for now! Thanks for your
> suggestion - if it comes up again I'll try it.

It could be that reopening the design removed this. In the latest versions
there is a cleanup function for both schematic and board at load.
Previous Topic: Re: Renaming same types of components with one command
Next Topic: Creating a library with the help of SMD, PAD, and another commands
Goto Forum: